Willekeurige lijst maken

Een alfabetische lijst in een willekeurige omzetten is eigenlijk een vorm van aselecte keuze zonder terugleggen. Dit is redelijk eenvoudig met een macro te doen, maar met alleen een formule is er al heel veel mogelijk.

Voorbeeld van willekeurige lijst maken

Dit voorbeeld bevat twee formules waarmee eenvoudig een bestaande lijst kan worden omgezet in een willekeurige
De formule is zo opgezet dat de lijst heel makkelijk kan worden uitgebreid voor een grotere lijst.
Er wordt gebruik gemaakt van de functies Aselect(), Kleinste(), aantal(), rij(),als()

  • plaats in a1: aselecte getallen
  • plaats in b1: originele lijst
  • plaats in c1: lijst in willekeurige volgorde
  • plaats in a2:
    =ALS(B2<>"";ASELECT();"")
  • plaats in c2:
    =ALS(B2<>"";VERT.ZOEKEN(KLEINSTE(VERSCHUIVING($A$2;0;0;AANTAL(A:A));RIJ(C2)-RIJ(C$2)+1);VERSCHUIVING($A$2;0;0;AANTAL(A:A);2);2;0);"")
     
  • Kopieer rij 2 naar de rijen 3 en lager om een lijst van x-aantal items in willekeurige volgorde te laten zetten.
  • plaats in cellen b2, b3 enz de namen of de lijstitems.
  • Druk op F9 om de lijst opnieuw te berekenen.