Bijvoorbeeld bij het produceren van een saldilijst of debiteurenlijst moet onderaan zowel het creditsaldo als het debetsaldo worden weergegeven. Dit betekent dat je alle negatieve getallen moet optellen en ook alle positieve bedragen moet optellen. In Excel is dit te doen met een standaard functie. namelijk Som.als(). De formule ziet er als volgt uit: =som.als(bereik van lijstje met getallen;voorwaarde;bereik van lijstje met getallen)

Negatieve getallen optellen

Het bereik is bijvoorbeeld A1:A6
Als voorwaarde gebruik je dan “<0” om de negatieve getallen op te tellen.

Positieve getallen optellen

Dit gaat zoals in bovenstaand voorbeeld is te zien op bijna dezelfde wijze. Positieve getallen optellen vereist alleen een andere voorwaarde: Nu gebruik je “>=0” als voorwaarde.

Voorbeeld negatieve getallen optellen

Hieronder een voorbeeld:
Selecteer alle cellen in onderstaande tabel en druk CTRL-c. Ga in een leeg Excelwerkblad staan in cel A1 en plak de selectiedoor CTRL-v te toetsen.

10  
-12  
-15  
11  
-7  
12  
   
=SOM.ALS(A1:A6;"<0";A1:A6) Alle negatieve getallen opgeteld
   
=SOM.ALS(A1:A6;">=0";A1:A6) Alle positieve getallen opgeteld